mike'sprojects‎ > ‎

Fixing a NEO-GEO MVS 2 slot board backup memory error

Background: I have a 2-slot Neo-Geo MVS arcade machine. My system is the smaller MVS-2-19 (the woodgrain cabinet). The MVS has a number of types of memory on board. For the moment, the important thing is the 'backup RAM', which holds the high scores and settings for the games that are in the system. If this memory isn't working, you can get all sorts of odd behavior because the settings might read out as illegal values. This memory is attached to a battery on the MVS board so that it retains it's contents when you turn the system off.

I recently got a new game for my MVS and when I played it, I noticed some odd behavior (it wouldn't let me end the game by dying!). Now since a game where you can't lose is kind of pointless, I had to try to fix it. 

First step was to clean the cartridge edge connectors, to no avail. I then poked around with the power supply a little bit (that's awful rusty - I think I need to replace that!) but I found no serious voltage issues.

The Neo-Geo forums indicated that I was dealing with a 'backup memory' issue, and suggested using test mode to reset the hardware memory. I tried that (on the MVS, you flip dip switch 1, and then power on the system to enter test mode). 

I was able to get to the 'reset backup memory' function, but doing so didn't seem to help any - I still had odd behavior. 

I went into test mode and tried to access the 'soft dips' (game specific settings) for the game, and found that the screen displaying the name of the cartridges was displaying garbage, and shortly after I entered the screen, the MVS would reset. I played with this a while, trying various combinations of resets and power cycles to no avail. 

I disconnected the battery (I had a remote ni-cad on there at the time) and left the system for a while. When next I turned it on, I got a 'Backup Ram Error   address 00D00000  write 5555  read 55AE' message on the screen and couldn't proceed any further (no test mode, no normal play mode). I went back to the forums for advice, and they said what I thought: the backup rams are in a bad way, the board needs work. 

I scrounged around on the net and came up with a schematic for the 1 slot board (come on SNK, release all the schematics - it's not like you sell these things anymore!). Fortunately, the MVS boards are all pretty much alike, so the circuit for the battery on the 1 slot is identical (at least at a schematic level) with the circuitry for the 2 slot. 

I removed the 'remote battery' connections I had setup entirely, in order to make it easier to work on the board. I started using my DMM and tracing out the components of the battery power circuit. I checked diodes, I checked that things were connected correctly, etc. I found nothing. 

Next up, I wanted to know which of the two memory chips was the one reporting bad - that way I could perhaps replace only one part. I found the chips (verifying their connection to the battery power circuit made it sure that I had the right chips), and I decided to check their control lines to figure out which one was which. The write control lines are sourced from a 74HC32 nearby. I started tracing and while I could get a signal from pin 8 of the HC32 to pin 27 of the appropriate chip, I couldn't seem to get a signal from pin 6 to pin 27 of the other chip. 

I then flipped the board over and started examining the traces. Pin 27 of the memory was connected on the front of the board to a via that went to the back of the board. From there, a trace carried the signal to pin 6 of the 74HC32 part. Probing the via and chip I found that the signal went just fine between them, but from the via to pin 6 of the 74HC32 there didn't seem to be a connection.

I inspected the trace with the biggest magnifiers I have and cleaned off some residue from a rubber pad that's normally stuck to the bottom of the board at that point. I finally found what appears to my eye to be a tiny nick in the trace. Apparently it had been there a while (presumably from a previous repair) and I guess oxidized to the point that it finally stopped working? 

I repaired the thing by running a wire from pin 6 of the 74HC32 to the via. After that, I put it all back together and it's working great!

My original question thread on the Neo-Geo forums: http://www.neo-geo.com/forums/showthread.php?228077-Aero-Fighters-2-won-t-let-me-fail